Showing results for 
Search instead for 
Do you mean 

ACT 2012 (APFW) Error when trying to choose a company

New Member
Posts: 3
Country: USA

ACT 2012 (APFW) Error when trying to choose a company

[ Edited ]


We recently upgraded our ACT installation from 2010 to 2012 and are running into a few different issues.  The first (and most prevelant) is that users cannot look up anything via the website.  When I try to search for a company, the results come up, but as soon as I click the name, I get the following in my event viewer:


MESSAGE: Object reference not set to an instance of an object.
QUERYSTRING: entity=Company&id=6174daaa-2def-4df9-9779-787768d7126f
TARGETSITE: Void HistoryTab_PreRender(System.Object, System.EventArgs)
STACKTRACE:    at Act.Web.HistoryTab.HistoryTab_PreRender(Object sender, EventArgs e)
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at System.Web.UI.Control.OnPreRender(EventArgs e)
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

For more information, see Help and Support Center at


The system then kicks me back out to the login screen.


I have tried clicking 'Company' on the left side of the webpage, but it ends with the same result. I have also tried clicking on Contacts and was kicked back out to the login screen.


Did we do something incorrectly with the upgrade? Is there an update or something I missed on the server that needs to be installed and the installer did not check for or apply?


It is running on a Windows Server 2003 box with SQL Server 2008 R2 Express installed.  The ACT software performed the database upgrade, and the thick clients seem to be working fine, it's just the web interface that is giving us a little grief.