Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2011 Web & NET 4.0

New Member
Posts: 4
Country: USA

ACT! 2011 Web & NET 4.0

Have static IP, running iis7.5 and have been accessing my ACT! 2011 through the web just fine for some time now.  Earlier this year I could not access my ACT! remote and was receiving error messages.  Finally tracked the problem down to NET framework issue.  Must have had an update that installed NET 4.0 which bumped my remote access to ACT!.  Uninstalled the NET 4 and iis was working OK again.  Over the weekend I upgraded QuickBooks 2011 to 2012 and noticed during the install it looked like it was installing NET 4.0 again.  Got to my office Monday to try and access ACT! and sure enough, no connection.

 

Is there a way to get 2011 working with NET 4 so I don't have issues with other programs that do want that version?  QuickBooks is critical and I can not have any issues with my accounting.  Not sure if the 2012 version will run OK with NET 3.5 or if it HAS to have NET 4?

JJ

I may not know what I'm doing when I start but I will by the time I'm done.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! 2011 Web & NET 4.0

2012 SP2 and 2013 now use .Net 4

But, you can configure IIS virtual folders to use different versions of .Net

With IIS 6.0, this was done in the vd properties
In IIS 7.0, it's done in the Application Pools
New Member
Posts: 4
Country: USA

Re: ACT! 2011 Web & NET 4.0

Good to know that 2013 is using NET 4.  Not sure If I just upgrade to 2013 if this will resolve the iis issue or if I will still need to manualy reconfigure the setting.

 

Never fails...upgrade one thing and it busts something else....

I may not know what I'm doing when I start but I will by the time I'm done.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! 2011 Web & NET 4.0

New Member
Posts: 4
Country: USA

Re: ACT! 2011 Web & NET 4.0

Win7 pro SP1 64 bit

iis 7.5.76

 

I may not know what I'm doing when I start but I will by the time I'm done.
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! 2011 Web & NET 4.0

Well, if ACT! was running, you must have already set IIS to 32bit or mixed-mode

Adding a .Net4 app shouldn't kill ACT! ... or at least you can set the app pool.

Bigger issue if the other app needs 64bit IIS