Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2010 for Web Premium Internet Sync

New Member
Posts: 1
Country: USA

ACT! 2010 for Web Premium Internet Sync

[ Edited ]

A Sage Sales rep helped to successfully install the trial ACT! 2010 for Web Premium on a Windows 2008 R2 server (hosted on the internet and not on a LAN) and on my laptop (client).  The server allows for use of the Web feature on our website.  Now, we are trying to get the Network Sync to work over the internet and we are both stumped (and he has over 10 years experience working with the product!).

 

1) The remote database is installed on my laptop (running Vista) and configured to sync over port 65100 (all permissions are granted over firewall and router)

 

2) On the server: The host DB is configured to "Accept Incoming Synchronization" and port 65100 is enabled and listening on the server (ports 65200, 1433 1434 are also enabled, but do not show up as "listening" whe I do a cmd "netstat -an" command) . Firewall grants permission to the various ports, as well.

 

3) Network sync service is running (configured over port 65200 using "actdiag").

 

I have read the following posts and article and am getting nowhere as I Still get the same annoying error on my client: "ACT! is unable to connect to the sync server. Check to be sure'accept incoming sync' is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network. Contact you administrator for assistance."

 

 

Basically,  I would welcome any advice or referral to a consultant I could hire to resolve this sticky situation.  I cannot commit to purchasing the ACT!2010 licenses if we cannot roll this product out smoothly as a trial.

 

Thank you in advance.

 

Below are a list of resources I have used to troubleshootmy this sync problem . These were similar issues discussed in the forums; despite my efforts to replicate the solution,  but I did not have the same positive outcome:


http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=1753...

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=2593...

 

http://community.act.com/sage/board/message?board.id=ACT&message.id=25904

 

http://community.act.com/sage/board/message?message.uid=72182

 

Greig Hollister is the man, he seems to know what he's doing and I wish he were around to assist.

 

[Edit: shortened link to fit on screen]

Message Edited by ghollister on 06-14-2010 10:27 AM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: ACT! 2010 for Web Premium Internet Sync

We are you trying both "accept Incomming syn" and the Network sync service?

 

Accept incomming sync is for Application sync

Silver Contributor
Posts: 1,813
Country: USA

Re: ACT! 2010 for Web Premium Internet Sync

Several things don'e make sense.  You seem to be combining all three types of sync, internet, network, and application.

 

LIstinging port is not set up via Actdiat but thourgh network sync services.  Needs to be the same on client and host.

 

Which one are you setting up?

 

Does it work inside the network?

 

We can set this up for you if you wish.

 

Test Drive Act! and Quickbooks over Citrix http://GoTryAct.com

Jon Klubnik| ActTrainer.com
(866)710 4228

ACT! Certified Consultant / ACT! Premier Trainer / ACT! Hosting Provider

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! 2010 for Web Premium Internet Sync

Hello tgassociates,

Welcome to the ACT! Online Community. I regards to your situation, there are a some keys points and some questions:

 

- Do your users have access to the network when offsite, such as VPN?

- Mike is correct in that if you are using Network Sync, then you do not need to have "Accept Incoming Syncs" checked, as this turns on the default sync service which you will not need.

- Make sure the remote databases can telnet to the sync port being used by the Network Sync Service (recommend 65100). If they cannot telnet to this port, then you have firewall issue or router issue.

- Make sure full permissions have been granted to your users for the following directory: C:\Program Files\ACT\ACT for Windows\ACT Network Sync

- Make sure all of the following program and port exceptions have been added to the firewall on the server:

 

Programs

C:\Program Files\ACT\Act for Windows\actsage.exe

C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe

 

Ports

TCP Port 1433

UDP Port 1434

TCP Sync port (65100 by default)

Dynamic SQL TCP Port (instructions to find below)

 - From the Start menu, type actdiag in the Search box

 - When ACT! Diagnostics opens, click Server, then Server Security

 - The dynamically assigned TCP/IP port will listed in the bottom half of this screen

 

There are basically 3 ways you can setup sync over the Internet:

1. Through a VPN. This a very secure and reliable way to sync, although a little bit slower than other methods.

2. Internet Sync Service. This service comes with your Premium product and basically syncs via a URL. For ACT! 2010, see KB Article 25192.

3. Network Sync via the Internet. This requires port forwarding on your router, which your network admin will need to setup. See KB Article 17536 for more information.

 

 

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.