Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 2010 Premium Won't Synchronize After Windows Vista Recovery

Copper Contributor
Posts: 8
Country: United States

ACT! 2010 Premium Won't Synchronize After Windows Vista Recovery

This past weekend we had to recover Windows Vista Home Premium 64-bit in the computer that houses the Publisher database, we did all of the Windows updates...and reinstalled ACT! on that computer; and then did the ACT! updates without any issues.

 

Prior to this Windows issue, three other computers were able to sync up without issue (well at least they would sync most of the time). Now none of the RDB machines will sync up, and every time I try a sync, I get the same message on all three systems..."ACT! is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the main database and that the Network sync service is running. Also be sure you are connected to your network. Contact your administrator for assistance."

 

#1 - The "accept incoming sync" and the Network sync service will not both run at the same time (as it suggests on the error message)...IF the network sync server is running, it isn't possible to enable "accept incoming sync," and vise versa. I have tried syncing with the Network Sync Server, and with the Accept Incoming Sync option checked; makes no difference.

 

#2 - All of my databases are running the same version...ACT! by Sage Premium 2010 Version 12.1.181.0, Hot Fix 1, and I verified that all of the Database Information is the same on all systems; which it appears to be.

 

#3 - The Network Sync Server (and the accept incoming sync) are both listen to port 65100.

 

#4 - All of the RDB's are monitoring port 65100.

 

#5 - Using Windows Explorer, I can see all of the shared folders on the hosting machine...and I have access to make changes on the hosting maching.

 

#6 - I am able to Share Database, open it and make changes, from any of the RDB computers that won't sync.

 

#7 - I followed all of the steps in ACT! Answer ID #24341...

...from the RDB computers, ping command found the computer hosting the Publisher database.
...from the RDB computers, the telnet found that we are connected (port 65100) and that it (telnet) was waiting; typed g, and got the reply as expected in the example.
...the netstat found the port on the hosting machine to be "listening."
...In Windows Firewall, I added these ports....TCP 1433, UDP 1434, and the Dynamically assigned TCP Port for SQL - which is 49968 (based on the Actdiag information on the Server Security.

...I made sure that all of the ACT! options were allowed to pass through the Firewall. (I even tried turning the Firewall completely off...no difference)

 

All of that, and a LOT more over the past three days, and I am really stumped as to why my RDB's won't sync...any ideas, or another path to try?

 

Thank you VERY much!

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! 2010 Premium Won't Synchronize After Windows Vista Recovery

[ Edited ]

Hello recoveryteam,

I will attempt to address your questions as you listed them:

 

#1 - If the Network Sync and the application sync service are both using the same port 65100, they cannot run at the same time (Windows will not allow two applications to use the same port simultaneously). If you have Network Sync running, then there is no reason to have application sync ("accept incoming syncs") running as well. Bottom line, if the Network Sync service is running, then uncheck "Accept Incoming Syncs".

 

#2 - Make sure your Network Sync service is at the same version as well (12.1.181). It's also possible the service is not running or may be damaged, so if needed you can uninstall and reinstall the Network Sync service. Also make sure that port 65100 is not being blocked. You can test by typing the command "netstat -a" from the DOS command screen, look for that port number and make sure it is "listening". If not, then you can try another port such as 65101 or 65200. You would need to have the remotes change the port number as well.

 

#3 - see response to #1

 

#4 - good

 

#5 - good

 

#6 - Make sure you have added the sync port as well (TCP 65100 in your case)

 

#7 - good

 

Some other things you can check:

- Make sure that User Account Control (UAC) has been disabled in Vista

- Make sure that during the recovery, the machine name of that Vista machine did not change. If it has, then the remote users will need to make this change on their machines

 

Hope this helps....

Message Edited by ghollister on 05-26-2010 10:21 AM

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.

Copper Contributor
Posts: 8
Country: United States

Re: ACT! 2010 Premium Won't Synchronize After Windows Vista Recovery

Hi Greg,

 

Thank you for your quick reply!  It is great to have your assistance out here!

 

Based on your assistance, I am finally able to synchronize using either the application sync service, or the Network Sync Server.

 

BUT....the Network Sync Server is not the same version as the Publisher database; it did not upgrade to 12.1.181.0 when I did the upgrade on the database.

 

If it is working just fine, do I need to upgrade the Network Sync Server from 12.0.409.0 to the 12.1.181.0 version?

 

Thanks again!

Platinum Elite Contributor
Posts: 6,537
Country: USA

Re: ACT! 2010 Premium Won't Synchronize After Windows Vista Recovery

Yes, I would advise doing this. While it actually does work with a different version, it is best the version of the sync service and the main program match to avoid potential schema issues. To acquire the latest version of the sync service, see KB Article 25930.

Greig Hollister

Note: Effective 6/1/13, Sage no longers provides support for the Act! software. This is now provided by Swiftpage.