Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! 16 and SQL Server 2008 R2 Compatibility

Accepted Solution Solved
New Member
Posts: 3
Country: USA
Accepted Solution

ACT! 16 and SQL Server 2008 R2 Compatibility

Fore warning, computer/tech savvy is not something anyone would ever say to describe me.  So, if you can dumb down your answers as much as possible, it would be greatly appreciated.

We keep having an issue with one of our remote databases that requires a batch fix (SQL2008R2_Express_BackupFix).  We are currently running Act! Pro Version 16.0.291.0 and SQL Server 2008 R2.  What combination of updates (service packs and/or hotfixes) to both are compatible and would fix the issue?  Thanks.


Accepted Solutions
Solution
Accepted by topic author SimonEnergy
‎01-21-2016 05:26 AM
Silver Super Contributor
Posts: 2,328
Country: USA

Re: ACT! 16 and SQL Server 2008 R2 Compatibility

The fix was originally in CU6 for SQL 2008 R2 SP1.  All of the prior updates are in SP3.  I was so long ago that this problem was discovered and resolved that I have forgotten exactly which issue it was that caused the problem in Act! but if you read through all the fixes in CU6 for SP1 you will probably be able to figure it out.  It doesn't happen to everyone so there hasn't been an Act! update that installed the updates to SQL but now that I think about it that would probably have been the way to go.  I created an installer that would install updates to SQL 2008 R2 and fix the problem on the SQL end but now that Microsoft has come out with SP3 which includes all the prior updates that's the simplest way to go.

 

Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!

View solution in original post


All Replies
Silver Super Contributor
Posts: 2,328
Country: USA

Re: ACT! 16 and SQL Server 2008 R2 Compatibility

You need to update SQL 2008 R2 to SP3 which includes all previous hotfixes.  You need to do that on all of the machines running a remote database for Act! and you need to run that batch file on all machines running either a remote database for Act! and the server that is hosting the Act! database.  All of them must be updated and have the batch file run before any of them sync again.  So stop the sync server, update all of them to SP3 and run the batch file on all of them and then start up the sync server again.  This is the result of a bug in SQL.  It is not an Act! issue but it created an Act! issue.

 

Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!
New Member
Posts: 3
Country: USA

Re: ACT! 16 and SQL Server 2008 R2 Compatibility

What "fix" in SP3 fixes the issue I'm having?  Also, what is causing my problem in the first place? 

Solution
Accepted by topic author SimonEnergy
‎01-21-2016 05:26 AM
Silver Super Contributor
Posts: 2,328
Country: USA

Re: ACT! 16 and SQL Server 2008 R2 Compatibility

The fix was originally in CU6 for SQL 2008 R2 SP1.  All of the prior updates are in SP3.  I was so long ago that this problem was discovered and resolved that I have forgotten exactly which issue it was that caused the problem in Act! but if you read through all the fixes in CU6 for SP1 you will probably be able to figure it out.  It doesn't happen to everyone so there hasn't been an Act! update that installed the updates to SQL but now that I think about it that would probably have been the way to go.  I created an installer that would install updates to SQL 2008 R2 and fix the problem on the SQL end but now that Microsoft has come out with SP3 which includes all the prior updates that's the simplest way to go.

 

Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!
New Member
Posts: 3
Country: USA

Re: ACT! 16 and SQL Server 2008 R2 Compatibility

[ Edited ]

Just realized I didn't specify we are using the Express version of SQL Server 2008 R2.  Does SP3 still work for the Express version?  Or is there a Service Pack for the Express version that fixes the problem as well?

 

EDIT:  There is no Express SP3.  There is an Express version of SP2 though, and that should still fix my problem since you said SP1 is really all I need?

Silver Super Contributor
Posts: 2,328
Country: USA

Re: ACT! 16 and SQL Server 2008 R2 Compatibility

The same service pack updates both versions.  That's the reason that it is so large.  You need to make sure that you get the version for the correct number of bits.  Usually most people install the 32bit version of SQL on 32bit operating systems and the 64bit version on 64bit operating systems.  Here is a link to the download.

 

https://www.microsoft.com/en-us/download/details.aspx?id=44271

 

Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!