Community
Showing results for 
Search instead for 
Do you mean 
Reply

Server Error in '/Act.Web.API' Application.

Accepted Solution Solved
Copper Contributor
Posts: 5
Country: Ukraine
Accepted Solution

Server Error in '/Act.Web.API' Application.

[ Edited ]

I have the problem after installation web API for ACT! Premium. Full error in attachment. ACT has version Version 19.0.155.0, web API latest - version 1.0.317.0.


Accepted Solutions
Solution
Accepted by topic author Vladimir
‎12-13-2018 12:39 AM
Copper Contributor
Posts: 5
Country: Ukraine

Re: Server Error in '/Act.Web.API' Application.

The problem was solved in two steps:

1. Update act to version 19.2.146.0 (maybe it's not required).

2. *.dll files in Act.Web.API\bin was replaced by files from ACT! directory. I think Act.Web.API has *.dll for framework v4.7 but the server has framework v4.0

View solution in original post


All Replies
New Member
Posts: 3
Country: United_Kingdom

Re: Server Error in '/Act.Web.API' Application.

I had this problem! I fixed it by removing the bindingRedirect in C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config for all the assemblies. Looking at your output it looks like it should be the same for you.

 

Solution
Accepted by topic author Vladimir
‎12-13-2018 12:39 AM
Copper Contributor
Posts: 5
Country: Ukraine

Re: Server Error in '/Act.Web.API' Application.

The problem was solved in two steps:

1. Update act to version 19.2.146.0 (maybe it's not required).

2. *.dll files in Act.Web.API\bin was replaced by files from ACT! directory. I think Act.Web.API has *.dll for framework v4.7 but the server has framework v4.0