Community
Showing results for 
Search instead for 
Do you mean 
Reply

Authorization issue

Accepted Solution Solved
Nickel Contributor m4y
Nickel Contributor
Posts: 532
Country: Belgium
Accepted Solution

Authorization issue

Hello

 

Trying to generate a token using authentication but I receive this error:

{ "message": "No HTTP resource was found that matches the request URI 'https://****************/Act.Web.API/api/authorize'.", "messageDetail": "No type was found that matches the controller named 'authorize'." }

No error like that on the /contacts but an obvious 401 unauthorized.

 

Any idea?

Thanks in advance


Xavier Nyssen

ACT! Certified Consultant @ Intuitis | Belgium
{ +32 64 45 08 00 | xavier@intuitis.be | http://intuitis.be }

Accepted Solutions
Solution
Accepted by topic author m4y
‎03-06-2018 12:26 AM
Employee
Posts: 240
Country: USA

Re: Authorization issue

There's no /API in the route for the Authorize resource.

 

Try this GET /act.web.api/authorize

 

then with the token in the authorize header GET /act.web.api/api/contacts 

View solution in original post


All Replies
Solution
Accepted by topic author m4y
‎03-06-2018 12:26 AM
Employee
Posts: 240
Country: USA

Re: Authorization issue

There's no /API in the route for the Authorize resource.

 

Try this GET /act.web.api/authorize

 

then with the token in the authorize header GET /act.web.api/api/contacts 

Nickel Contributor m4y
Nickel Contributor
Posts: 532
Country: Belgium

Re: Authorization issue

Good catch, the /API in the route was indeed the cause.

Thanks for your help

 


Xavier Nyssen

ACT! Certified Consultant @ Intuitis | Belgium
{ +32 64 45 08 00 | xavier@intuitis.be | http://intuitis.be }