Community
Showing results for 
Search instead for 
Do you mean 
Reply

"Error in the application" when Login to ACT!

New Member
Posts: 5
Country: United States

"Error in the application" when Login to ACT!

[ Edited ]

Hi,
We were trying to login to ACT! through 'ActFramework.LogOn( )' API in 'Act.Framework' Namespace,

Login failure in ACT! 11.1.183.0:
when we deployed this program in a machine which has ACT! version of "11.1.183.0" it throws the exception
stating "Error in the application." which was not caught in "ProductVersionMismatchException" Exception handler but in .NET "Exception" Class .

Able to Open database from ACT! and perform other operations in database..
Even tried creating a new database but issue still exists so we can conclude that problem is not with database.

This program works fine elsewhere except one machine 


ANY SUGGESTIONS TO RESOLVE WITHOUT RE-INSTALLING ACT!.

 

Thanks in advance.


Karthik.

Message Edited by Karthik on 04-23-2009 09:50 PM
New Member
Posts: 6
Country: United States

Re: "Error in the application" when Login to ACT!

You may have to copy the Act.Framework.dll assembly out of the GAC and reference it locally. You should also set the "Specific Version" property to false when referencing assemblies, so your code will work with later versions of ACT!.  This isn't allow with a GAC'd assembly.

 

Make sure the version of the ACT! Assemblies your referencing matches the version of ACT! you are trying to connect to. 

 


 

 

Gavin Stevens
MCPS, MCSD, MCAD, MCNPS
ACT! Developer
http://crmintegrationsystems.com
Copper Contributor
Posts: 12
Country: Australia

Re: "Error in the application" when Login to ACT!

[ Edited ]

Gavin,

 

I have the same exception being thrown. I have an ACT server (tiger) a web server (cheetah) and my dev box (rainbowfish). I have an ASP NET app which runs on cheetah and accesses the ACT! database on tiger. It works fine. I run it in debug on rainbowfish however and it does not work, this exception is thrown on log on.

 

I have copied ALL of the Act.* DLLs from the GAC on tiger to my local box, installed them in my GAC and used  a reference to three of the same DLLs in my project:

 

Act.Framework

Act.Shared.Collections

Act.Shared.Components

 

They are ALL version 11.1.183.0.

 

I have turned "Specific version" off on my local build as suggested with no luck (nor would I epxect it as I have the same versions all around. 

 

I'm stuck. 

 

Works well form one machine, not the other. I don't have Act! installed on rainbowfish, nor do I want it (if it can be avoided). The server (tiger) has "ACT! by Sage Premium 2009 installed  and my web server (cheetah) has "ACT! Premium for Web" installed.

 

Am, I to conclude Cheetah works because "ACT! Premium for Web" is installed?

 

A pretty poor exception really in terms of lucid feedback.

 

Bernd.

Message Edited by bwechner on 01-27-2010 10:12 PM