Community
Showing results for 
Search instead for 
Do you mean 
Reply

iPlugin and ActApplication have stopped working

Accepted Solution Solved
Copper Super Contributor
Posts: 88
Country: USA
Accepted Solution

iPlugin and ActApplication have stopped working

Hi:

 

I upgraded my ACT!2011 to the latest SP and Hotfix.

 

Since then, my "Implements iPlugin" code returns an error that it cannot be found. Also, "ActApplication" also returns an error.

 

Did I miss something?

 


Accepted Solutions
Solution
Accepted by topic author kimkamp22
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 88
Country: USA

Re: iPlugin and ActApplication have stopped working

I found out that the file "Act.UI.dll" was no longer registered. So... I reinstalled the latest HotFix, which registered that file, and now all is well.

View solution in original post


All Replies
Employee
Posts: 1,163
Country: USA

Re: iPlugin and ActApplication have stopped working

Is the plug-in still loading? If not you will find the name of the plug-in added to %appdata%\ACT\ACT Data\DependentDlls.xml. You can delete this file to have act attempt to reload the assembly. I've also run into this error before when installing a new version. You may need to delete your preferences (everything below \\ACT Data).

Matthew Wood
Act! SDK Support
Community Moderator
Copper Super Contributor
Posts: 88
Country: USA

Re: iPlugin and ActApplication have stopped working

Thanks for the reply.

 

Actually, it is in the VB.NET coding that I get the error. And, it is only happening on one machine (a laptop). My office machine compiles and runs the Plugin perfectly.

 

The Plugin I compiled before the upgrade on the laptop also loads fine. I can't compile the Plugin on the laptop until I figure out the problem.

 

It seems to be a problem with the dll's - but why on one machine (after upgrading) and not the other?

Employee
Posts: 1,163
Country: USA

Re: iPlugin and ActApplication have stopped working

[ Edited ]

I've occasionaly had strange/quircky issues with my references, you could try dropping and re-adding them to the solution and see if that resolves it.

Matthew Wood
Act! SDK Support
Community Moderator
Copper Super Contributor
Posts: 88
Country: USA

Re: iPlugin and ActApplication have stopped working

OK - I'll try that.

 

Thanks for the info!

Solution
Accepted by topic author kimkamp22
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 88
Country: USA

Re: iPlugin and ActApplication have stopped working

I found out that the file "Act.UI.dll" was no longer registered. So... I reinstalled the latest HotFix, which registered that file, and now all is well.