Community
Showing results for 
Search instead for 
Do you mean 
Reply

Type or Namespace issue

Accepted Solution Solved
New Member
Posts: 3
Country: USA
Accepted Solution

Type or Namespace issue

Hi Gang,

I've been tasked with developing/testing ACT!17 with the SDK

 

I've downloaded various samples (VB and C# - equally comfortable in both languages), and have updated the reference path to my local copy of the GAC (latest SDK I could find was 16), and updated the sample's references to point to the correct DLLs

 

When I go to build the sample(s) I get

The type or namespace 'Act' could not be found (are you missing a using directive or an assembly reference?)

 

Interestingly, when I go to type in a new Using reference, the Act namespace pops up, and you can type the . and see the sub namespaces!

 

I'm totally confused


Accepted Solutions
Solution
Accepted by topic author cgallo@blueskymls.com
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 41
Country: USA

Re: Type or Namespace issue

Try setting the framework 4.0

 

Bob Lozinak
Twelve/Three Marketing, Inc.
Software Developer

View solution in original post


All Replies
New Member
Posts: 3
Country: USA

Re: Type or Namespace issue

further info.

The error I'm getting

The type or namespace name 'Act' could not be found (are you missing a using directive or an assembly reference?)

 is actually pointing TO my using statements - to whit

using Act.UI;

using Act.Framework;

etc

The project is the VCSPluginTemplate downloaded from this forum

I have updated the Projects Reference Paths

I have updated all the References in the project

I have set the project to x86 and Framework 3.5

 

Interestingly, if I am in the IDE, the Intellisense SEES and gives me the options for Act.XXXX, it just won't compile

 

Solution
Accepted by topic author cgallo@blueskymls.com
‎09-25-2015 03:20 AM
Copper Contributor
Posts: 41
Country: USA

Re: Type or Namespace issue

Try setting the framework 4.0

 

Bob Lozinak
Twelve/Three Marketing, Inc.
Software Developer
New Member
Posts: 3
Country: USA

Re: Type or Namespace issue

That did it.  All the samples and instructions I saw EXPLICITLY said to set it to 3.5.  Sigh.  Will it work with 4.5? (I'll try myself, but do you know of any problems)

 

We can mark this as 'solved' - but don't know how

Copper Contributor
Posts: 42
Country: Germany

Re: Type or Namespace issue

I target .Net Framework 4.5.2 and have not seen any problems to date.