Community
Showing results for 
Search instead for 
Do you mean 
Reply

SDK Notification regarding v21.1

Moderator
Posts: 800
Country: USA

SDK Notification regarding v21.1

We’ve received reports that the version numbers in DLL files referenced in our Act! SDK may cause issues with development projects that target Act! for Web specifically.  Though the version numbers are inaccurate, the files themselves work appropriately.  We strongly suggest that you instead develop your application to target a minimum version number as opposed to looking for a specific version DLL.

 

We’ve tested current applications on our cloud environment and have not run into any issues with this version mismatch.  If your application is having a problem, please respond below with the details.

Billy Clark
Swiftpage
Act! Knowledgebase: http://kb.act.com
Highlighted
Copper Super Contributor
Posts: 45
Country: Germany

Re: SDK Notification regarding v21.1

[ Edited ]

Hi fellow sufferers (I hope Google have translated this correctly),


here is an example of some Act! Premium for Web assemblies:


In Act! 21.0 the following assemblies have the version: 21.0.204.0


Act.Web.dll

Act.Web.Framework.dll

Act.Web.Framework.Core.dll

 

(You can find these dlls in the <ActInstallationFolder>\APFW\bin)


In Act! 21.1 (newer version of Act!) these assemblies have an older version: 21.0.184.0


It seems that someone have forgotten to increase the sub version.


Best regards

Robert

Melville-Schellmann
Consulting and Development for CRM-Software