Community
Showing results for 
Search instead for 
Do you mean 
Reply

References to previous versions cause error?

Copper Contributor
Posts: 87
Country: USA

References to previous versions cause error?

Program that used to work now fails.

 

Program compiled with references to v10.0.2 GAC dll's, on machine running 10.2.  Works fine on machine that upgraded from v10 to v11.  New machine started with v11.  When starting that program on that new machine, program fails with Sytem.IO error that the Act.Framework.dll file is not available.

 

What's the trick for a machine with only the latest version to successfully run a program compiled to be compatible with older versions?

 

(Never had this problem before - code compiled with v7.0 libraries always worked on machines with newer versions as well.)

 

Thanks in advance,

Geoff

Geoff Blood ("The ACT! Customizer" )
The New Hampton Group

ACT Development Partner
Serving the ACC community since 1994
New Member
Posts: 6
Country: United States

Re: References to previous versions cause error?

[ Edited ]

Should work fine as long as your manifest isn't exclusively referencing a specific assembly version.   Make sure all your ACT! references in your project are set to "specific version = false"

 

For GAC'd assemblies you cant specify this, in that case, copy the .dll files out of the GAC to a local folder and reference them explicity in that location instead of thier GAC's version...

 

I compiled my addon app against the 10.0 release and it works fine all the way upto 11.1.183...

Message Edited by CRM Integration Systems on 05-19-2009 04:44 PM
Gavin Stevens
MCPS, MCSD, MCAD, MCNPS
ACT! Developer
http://crmintegrationsystems.com