Community
Showing results for 
Search instead for 
Do you mean 
Reply

Plug-in doesnt load on re-installing .net framework 2.0

New Member
Posts: 7
Country: Pakistan

Plug-in doesnt load on re-installing .net framework 2.0

[ Edited ]

hello everyone.
i am having some problem with loading plugin in ACT. here i m writing the complete scenario of my execution.

 

1. I have developed a class library in C#.NET using framework 2.0 
2. I have implemented IPlugin interface methods and display messagebox in each method. and i have done complete exception handling in plugin class.
3. in plugin load method, i added some command bar buttons in Tool menu.

4. I made an installer using Null-Soft software, which place DLLs in "c:/Program Files/Act/Act for windows/Plugins/" path. 

5. I run the plugin setup. It installed successfully. then, I run Act!, it display all message boxes that i have placed in Plugin Load method. and it showed the created button in Tool menu successfully without any single error.

6. I checked the "LogView.exe", it displayed no error. and i checked "Dependentdll.xml", my plugin Dlls names were written in this xml file, but my plugin was working fine.

 

7. then i un-installed the .NET framework 2.0 from my system.

8. after this, Act! didnt run.

9. then i re-install the .NET framework 2.0.

10. Now i run the Act! software. But this time Act! didnt load my plugin. i surprized. I checked the "LogView.exe" again, it displayed no error. my plugin Dlls names were still placed in "DependentDlls.xml" file. i tried to remove these entries from DependentDlls.xml, but Act! created these entries again.

11. then i un-installed and then re-installed my plugin. but it never loaded again.

12. i tried many ways but it didnt load my plugin. the only scenaria i found is that, un-install the Act! software and re-install it. then it will load my plugin.

But i couldnt find out the rout cause analysis of this plroblem that why my plugin didnt loaded on re-installing .net framework 2.0

 

one thing more.... i tried the same scenario not only with my plugin, but i tried this scenario with "SPEACT" plugin which is available at "http://www.swiftpage.com/plugins_download/SPEACT_6000.exe"

 

i m using ACT! 2009 version, but this problem occurs on each version. 

 

Regards,
Shahid Mehmood
http://www.technoBlogy.net

Message Edited by shadysaim on 01-01-2009 09:58 PM
Silver Super Contributor
Posts: 2,328
Country: USA

Re: Plug-in doesnt load on re-installing .net framework 2.0

Shahid,

 

If it was working and you uninstalled .NET 2.0 and reinstalled it and it still doesn't work I'm guessing it's a version compatibility issue with .NET 2.0.  I would make sure that you are running the latest service pack of .NET 2.0.

 

Stan


If you would like to get more out of ACT! you can find an ACT! Certified Consultant near you by going to:www.act.com/acc.
-------------------------------------------------------------------------------------
Stan Smith
ACT! Certified Consultant
ADS Programming Services, Inc.
(205) 222-1661
www.adsprogramming.com
www.actwebhosting.com
Click Here to Purchase Act!
Copper Super Contributor
Posts: 138
Country: United States

Re: Plug-in doesnt load on re-installing .net framework 2.0

Shahid, if you have not done so already, try reading thru Xavier's blog about this subject at:

My Add-on No Longer Works What Now

 

Also, in the ActSage.exe.config file, try increasing the diagnostic switches up from "1" to "3" for more informational messages, that may help identify the issue.

 

Bill Blakey
ACT! Development Team
Sage Software