01-16-2013 09:02 AM
I used to be a .NET 2.0 guy since that made most of my ACT! stuff forwards compatible but am moving to VS 2012 and working on at least one project that will target .NET 3.5 and getting my hands dirty in WPF.
Can anyone clarify the gotchas on using .NET 3.5 with older versions of ACT!?
For example, if I build a plugin that targets .NET 3.5 on a machine that has .NET 3.5, but ACT! is using .NET 2.0 (like v2007 - 2010, I think) will it work or no? ACT! 2011 is the first to use .NET 3.5, right? I know that 2, 3, and 3.5 use a common CLR but not sure how that plays out with loading plugins.
I quit doing ACT! 2005/2006 stuff years ago because I didn't want to deal with .NET 1.x anymore but am not quite ready to give up on .NET 2.0 altogether if it means only developing for ACT! 2011 and later, although in some cases I will.
01-16-2013 09:30 AM
01-16-2013 09:48 AM
Generic collections and lambda expressions are definately FTW! Initially I couldn't really see the point of lambda exps but code with them becomes so much more succinct and easier to read (especially since I am really bad at documentation *blush*). They don't really give much towards improving code performance (maybe infact reduce it to be honest), but then for the average ACT! plugin project, we're going to be talking about micro-efficiencies vs ease and self-documentry code.
Most of my simple 3.5 plugins work fine "un-forked" in 2013, thanks to fine folks in the Sage dev team researching the workaround in the 4.0 implementation for 2013.
01-16-2013 10:07 AM - edited 01-16-2013 10:12 AM
We compile against .NET 2.0 for all version of ACT! Including 2013.
In-house we use VS 2008 and VS 2012 as dev environments but always do the release builds using VS 2008 for Impact Suite v4. V4 is our current release which supports ACT 2010, 2011, 2012 and 2013
We now compile using VS 2012 when working with APFW since our new Impact Suite v5 Web Version requires APFW 2012 SP1 or better.
At least for the next few years I do not see moving our build machine off VS 2008.
** Sidenote1 - Impact Suite require ACT! 2010 or better since we use the OLEDB.2reader.
** Sidenote2 - Love. love, love lambda expressions. Not just for readability but because they are the key problem solvers in the APFW SDK!
Hope this helps
-- Jim Durkin
01-16-2013 10:18 AM
01-16-2013 01:18 PM
Yeah I know 2013 uses 4.0, but the new project needs to run for v2011 and later, so I'm going 3.5 unless convinced otherwise.
01-16-2013 01:31 PM
Vivek, your stuff written in 3.5, how far back does it work (which ACT! version) and they do have to install .NET 3.5 as a pre-req if they're on a version of ACT! that hasn't already installed it, right? (which I think is 2010 or earlier, but not sure)