Community
Showing results for 
Search instead for 
Do you mean 
Reply

Load Libray(ACT.Framework.dll) Failed

Copper Contributor
Posts: 6
Country: USA

Load Libray(ACT.Framework.dll) Failed


Hi All,


 I am  using ACT! SDK to interact with ACT!. Actually I have one C# component which will interact with ACT! API. UnMangaed dll component do a  "CreateInstance"   to use the above C# component. The C# component will be registered using "RegAsm" .Net Tool. It throws up the error message as follows...


"RA0000:Could not load assembly file or assembly 'Act.Framework.Version=9.0.175.0. Culture= neutral, PublicKeyToken=ebf6b2ff4088a' or one of its depedencies.The system cannot find  the file specified."

The above C# component uses the following ACT! dlls. Act.Framework.dll Act.Shared.Collections.dll and so on.

I tried to uninstall and install the ACT.Framework.dll using Regsvr32 but it throws an error message while uninstalling itself

 "LoadLibrary failed - The specified module could not  be found". How i have to  resolve this kind of  issue?


Thanks For Advance

 Jagadeesh

Copper Contributor
Posts: 98
Country: United States

Re: Load Libray(ACT.Framework.dll) Failed

[ Edited ]
Without more detail or looking at the system directly here are some steps you can take.
 
From Xavier's Blog:
 

So you've written an ACT! add-on, and for whatever reason, it is no longer being loaded by ACT!.  What do you do?  There's several steps that are particularly useful in determining the cause and getting it working again.

1. Check the ACT! Log 

Chances are, the add-on threw an exception, which was caught by ACT! and logged.  The caught exception will have a full stack trace along with the exception, which should give you insight into what happened.  There are several ways to check the log.  You can simply run Logview.exe, which can be found in the ACT! install directory, or if you're XML adventurous, you can look at the raw file (ACTLOG.XML) located in the ACT!'s application data folder (note folder location varies per OS).

2. Use the .NET Framework Assembly Binding Log Viewer (Fuslogvw.exe)

When any assembly cannot be loaded by the .NET Common Language Runtime (CLR), entries can be logged and viewed using this tool (http://msdn2.microsoft.com/en-us/library/e74a18c4(vs.80).aspx).  A common problem for an Add-on to stop working is that it itself cannot be loaded, or one of its dependent assemblies cannot be loaded, often because of version mismatch.  Fuslogvw.exe is a very powerful tool which can provide what assembly version is attempted to be loaded and where, and what the failures were.  This can often give you key information to resolve the problem at hand.

3. Re-Enable the Add-on

Ok, so you've found the issue, and fixed it. So why isn't it working?  Any time ACT! encounters an unhandled exception when loading an add-on (either when loading the type or when calling the constructor), the assembly the add-on resides in will be marked as unsafe, and ACT! will skip loading it in subsequent runs.  Also in the ACT! application data directory is a file named Dependentdll.xml.  You'll want to check that file for your assembly name, and remove that entry. 

 

I hope this helps out any of you add-on authors that happen to run into any load or initialization issues with your add-ons.  Keep making great ACT! add-ons!



Message Edited by Carlton_Jones on 03-06-2008 05:40 PM
Carlton Jones
Sage Software
New Member
Posts: 1
Country: United States

Re: Load Libray(ACT.Framework.dll) Failed

ACT Library (Dlls) must reside into the Global Assembly Cache (C:\windows\assembly) to work with Visual Studio.Net.

 

You can not copy your dlls into this folder directly by copy/paste, rather you have to add them using gacutil.exe (resides in the C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\Bin or C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v2.0\Bin) at command line.

 

e.g; C:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\Bin\gacutil.exe /i c:\mydll.dll

 

Hope it will work.

 

Regards,
 
 
Uzair Tahir
(Sr. Software Engineer)
 
Abacusoft Corporation
1055 E Colorado Blvd., Suite 500,
Pasadena, CA 91106-2327
Nickel Super Contributor
Posts: 441
Country: UK

Re: Load Libray(ACT.Framework.dll) Failed

Is this error happening on the machine you are building the plugin on or another one?

 

Tom