Community
Showing results for 
Search instead for 
Do you mean 
Reply

IContactListBoundControl and ACT! 2010 Not working

New Member
Posts: 5
Country: USA

IContactListBoundControl and ACT! 2010 Not working

Is it me or is anybody else experienceing a problem using a custom control using the IContactListBoundControl. It appears that nothing is showing up in thie custom control.

 

To test this i took the sample file that gets shipped with the 2010 SDK names ContactNameControl.cs located in  ContactNameControl.zipand added to a blank solutions, included the ACT.Framework, Act.Framework.ComponentModel.Core, Act.Shared.Collections and the Act.Shared.ComponentModel compiled and copied to my ACT! install. Nothing shows up in this control, where is should show the contact name.

 

I this no longer supported in the ACT! 2010 SDK, is there another way to making this sample work or wht is recommended way for cerating a control using the ACT! 2010 SDK?

 

Thanks

 

John

Nickel Elite Contributor
Posts: 937
Country: USA

Re: IContactListBoundControl and ACT! 2010 Not working

That interface should still be available - you might want to check to see what version of ACT! 2010 you have as some beta builds had this interface deprecated.

 

Instead of using this interface it is recommended you use the IMutableEntitylistBoundControl interface moving forward.   

 

I've just posted some examples to the devnet downloads forum that should provide an example of this.

 

 

New Member
Posts: 5
Country: USA

Re: IContactListBoundControl and ACT! 2010 Not working

Allen, Thanks, What are the samples called? I was checking out the forum but couldnt see anything that was posted on the 21st.

 

Thanks

Nickel Elite Contributor
Posts: 937
Country: USA

Re: IContactListBoundControl and ACT! 2010 Not working

The code example in this post shows an example of using IMutableEntityListBound... Interface:

 

http://community.act.com/sage/board/message?board.id=ADN_Downloads&thread.id=226