Community
Showing results for 
Search instead for 
Do you mean 
Reply

Getting error on plugin unload and ACT! closing

Copper Super Contributor
Posts: 88
Country: USA

Getting error on plugin unload and ACT! closing

Hi all:

 

I'm getting an error message when I close out ACT! with my custom Plugin loaded:

 

"Problem signature:
  Problem Event Name:    CLR20r3
  Problem Signature 01:    actsage.exe
  Problem Signature 02:    15.1.108.0
  Problem Signature 03:    50c1143d
  Problem Signature 04:    System.Data
  Problem Signature 05:    4.0.30319.18047
  Problem Signature 06:    51553556
  Problem Signature 07:    1835
  Problem Signature 08:    14
  Problem Signature 09:    DDTYH4CRNQI0JCB1XJKWM10Z55WSA2SJ
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    1033
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789"


In my logfile, the following is occuring when I close out ACT!:

 

5/22/2013 1:53:13 PM    HostApplicationBeforeLogoff() - Start
5/22/2013 1:53:13 PM    RemoveMenuItem() - Start
5/22/2013 1:53:13 PM    RemoveMenuItem() - End
5/22/2013 1:53:13 PM    HostApplicationBeforeLogoff() - End
5/22/2013 1:53:13 PM    OnUnLoad() - Start
5/22/2013 1:53:13 PM    OnUnLoad() - End

 

Any suggestions?

Employee
Posts: 1,163
Country: USA

Re: Getting error on plugin unload and ACT! closing

Just a stab in the dark based on what's here, it may be trying to remove a menu item that has either already been removed or was never added, you could double check the urn to the menu items and debug through and see if there's being found/added/removed as they should be.

 

To get some more details you can dial up the logging levels in ActSage.exe.config (or Act!.exe.config if you're using version 16 alpha).

 

<switches>
<!--Logging Levels: value =
0 – Off
1 – Error
2 – Warning
3 – Info
4 – Verbose
-->

<!-- New High Level Log Categories - beginning with ACT! 12.1 -->
<add name="ACTCommonSwitch" value="1"/>
<add name="ACTFrameworkSwitch" value="1"/>
<add name="ACTApplicationSwitch" value="1"/>

 

 

Close Act, change the value to 4, run Act, shut it down to recreate your error then check the log file again. Remember to turn the log levels back down.

Matthew Wood
Act! SDK Support
Community Moderator
Bronze Super Contributor
Posts: 1,231
Country: USA

Re: Getting error on plugin unload and ACT! closing

2nd shot.
You are still listening to an event in the ACTUI and on dispose you are referencing an ACT UI object that is disposed or null.
Jim Durkin