Community
Showing results for 
Search instead for 
Do you mean 
Reply

GetTaggedCompanies problem

Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

GetTaggedCompanies problem

Hi,

 

I'm wondering if there is a bug or I'm just going about it completely wrong! I'm trying to write a very simple little plugin that allows the user to manually select companies in list views and just look up those or limit the list to just those.

 

I thought in SDK parlance, this was via the CompanyManager.GetTaggedCompanies(sortCriteria, companyList). The problem is it seems to just result in a null each time? I even tried approaching from 

 

actApp.ApplicationState.CurrentCompanyList.TaggedItems.GetTaggedKeys()

 

but that also returns null! 

 

Is there a bug or what am I doing wrong? This little 5 mins job is driving me nuts now!

 

Oh ACT! 14 Framework.

 

TIA

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
Employee
Posts: 1,163
Country: USA

Re: GetTaggedCompanies problem

This isn't working for me either, are you getting empty collections or are the results null? It returns a collection for me, but it's always empty regardless of whether I'm in edit mode or not. I had the same results attempting to do this with contacts as well. 

 

I want to make sure we're getting the same results before I report this.

Matthew Wood
Act! SDK Support
Community Moderator
Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Re: GetTaggedCompanies problem

Hi Matthew,

 

I'm feeling a bit embarassed now, I was a bit loose in my wording. Yes I get empty collections, since the methods feed other methods upstream they result in nulls so that was why I was saying null. Sorry!

 

I'm glad its not just me doing something silly!

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog