Community
Showing results for 
Search instead for 
Do you mean 
Reply

Fields Keep losing focus???

Accepted Solution Solved
Copper Super Contributor
Posts: 71
Country: Canada
Accepted Solution

Fields Keep losing focus???

Hello Forum,

 

So I have been using a field changed event to trigger some code, works great except for one thing. When I am typing into fields on the contact layout, for example when adding a new contact record, I could be typing in the address field and half way through typing the address my cursor dissapears and loses the focus on the field so I have to click back into the address field to finish it off. It is extremelly annoying and does this quite often, is there something in my code that could cause this, a refresh for example??


Accepted Solutions
Solution
Accepted by topic author MattRobillard
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 71
Country: Canada

Re: Fields Keep losing focus???

My apologies you are right, it does this even without the plugins. Thanks.

View solution in original post


All Replies
Employee
Posts: 1,163
Country: USA

Re: Fields Keep losing focus???

It's likely not an issue with your code. The most common cause for this issue is background applications.

Matthew Wood
Act! SDK Support
Community Moderator
Solution
Accepted by topic author MattRobillard
‎09-25-2015 03:20 AM
Copper Super Contributor
Posts: 71
Country: Canada

Re: Fields Keep losing focus???

My apologies you are right, it does this even without the plugins. Thanks.

Copper Super Contributor
Posts: 112
Country: Australia

Re: Fields Keep losing focus???

[ Edited ]

No. its ACT that is doing it and not a background application..

 

easy way to show it, is to open act (and make sure ACT opens to the contact screen).. as soon as its open pick a field and highlight the text in it and wait

give it 10sec and the field looses focus.. happens EVERY time

 

to show that its not even a mouse thing, just open ACT using the demo db, again with ACT opening with the contact screen.. when it opens you can see the cursor flashing in the contact field.. give it 10sec and the cursor disappears..

 

there are other times this happens (doesnt have to be when ACT opens) most likely when ACT is checking something in the background it will take focus away from what you are doing

 

its very alloying and is NOT a background application causing it to loose focus.. i have people asking me ALL the time whats causing it and to fix it so it doesnt keep doing it.. 

Bronze Super Contributor
Posts: 1,231
Country: USA

Re: Fields Keep losing focus???

Could it be the background load of the other views?  To increase startup performance ACT! delays the loading of view like company, group, opportunity, task and calendar. I think they spin up off a timer .  

 

You can change the timer interval by editing the ActSage.exe.config file. Here is the section you may want to change.

 

    <!-- Number of seconds after contact detail view is shown to background load other views
       for faster view switching performance (note: 0 seconds means don't background load view)-->
    <add key="BackgroundLoadTaskView" value="15"/>
    <add key="BackgroundLoadCalendarView" value="30"/>
    <add key="BackgroundLoadGroupView" value="45"/>
    <add key="BackgroundLoadCompanyView" value="60"/>
    <add key="BackgroundLoadOpportunityView" value="75"/>
    <add key="BackgroundLoadActivityNotification" value="20"/>
    <!-- Pre-Loads portion of ACT! for faster startup -->
    <add key="FastLoadEnabled" value="true"/>

 

-- Jim Durkin