Community
Showing results for 
Search instead for 
Do you mean 
Reply

Custom Entities

Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Custom Entities

Hi,
 
Just a quick question and I have to admit I am being a bit lazy since I haven't installed the 10.0.2 yet myself, but does anyone know if the Custom Entity tables exposed by the OLE-DB Provider?
 
TIA
Vivek
Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
Employee
Posts: 236
Country: USA

Re: Custom Entities

Yes, custom tables created via the SDK will show up via the OLEDB provider.
Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Re: Custom Entities

Cool!
Cheers for the reply Xavier.
 
Vivek
Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
Copper Super Contributor
Posts: 138
Country: United States

Re: Custom Entities

Vivek (and others), what have your experiences been so far with Custom Tables and the OLE/DB Provider?
 
  • Did the VRP_ views appear after creating your sub-Entity then connecting via the ACT! OLE/DB Provider?
  • Were the VRP_ views named as you would have expected?
  • Do the views have the design you expected?
  • Did you expect to have the field names (columns) entity-prefixed as the legacy view do?

Any comments, observations and feedback would be great to hear!

Thanks.

Bill Blakey
ACT! Development Team
Sage Software

Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Re: Custom Entities

Hi Bill,
 
I'm just waiting for the 10.0.2 update to be made available for the UK Premium version. I was not sure if I could use the Premium Web UK version. I think I may just download it to a VM and start testing. As soon as I have done that I will update this thread.
 
Vivek
Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
New Member
Posts: 4
Country: Canada

Re: Custom Entities

Hi Bill,

 

I've had an issue with Custom Tables and the OLEDB provider in one particular database and I'm hoping to get some insight as to what I can do.

 

I had my custom tables show up in the table list, but something happened and they dissapeared.

 

I cracked the database open and they still appeared in the VRP view list.

 

I just need a quick fix, so what views and or tables control the Views visible to the ACT! OLE DB provider?

Copper Super Contributor
Posts: 138
Country: United States

Re: Custom Entities

Let me try to address each item:

 

"I had my custom tables show up in the table list, but something happened and they dissapeared."

So where did you see a table list?  What action did you take before they disappeared? 

 

"I cracked the database open and they still appeared in the VRP view list."

Same type questions, cracked db open using what software?   

 

"I just need a quick fix, so what views and or tables control the Views visible to the ACT! OLE DB provider?"

The Views that are exposed via the ACT! OLE/DB Provider are prefixed with VRP as you mentioned.  I would suggest rebuilding them using ActDiag (Start>Run>ActDiag.exe):

1. select the Databases panel

2. select the database in question, then right-click (or Actions menu)

3. select Database Fixes, then Rebuild OLE/DB Report Objects

 

See if that resolves your issue.

 

Bill Blakey
ACT! Development Team
Sage Software

New Member
Posts: 4
Country: Canada

Re: Custom Entities

So here are my answers:

 

"So where did you see a table list?  What action did you take before they disappeared?"

 This list was pulled using Crystal Reports through the ACT OLE DB provider.

 

"Same type questions, cracked db open using what software?"

 To have a peek inside to see if there was anything obviously wrong, I took the database and attached it to a SQL standard instance so I could take a look using management tools.

 

"Use Rebuild OLE/DB Report Objects using ACTDiag."

 Tried that, still only get the standard list as if there were no custom tables.

 

One thing to keep in mind is that this appears to be database specific. The weird thing is that the VRP tables look correct when I'm viewing SQL using management tools, but when I'm using the OLE DB provider through Crystal, that's when I run into problems. Other databases with custom tables seem to be OK.

 

Let me rephrase my question: What tables or views inside of the ACT database decide what should be visible to the OLE DB provider?

 

Regards,

 

David Nastrom

Copper Super Contributor
Posts: 138
Country: United States

Re: Custom Entities

None of the tables (TBL_, CTL_, CUST_) should be visible to the ACT! OLE/DB Provider.  Only the Reporting Views (VRP_) should be seen.

 

So you're seeing the VRP_ Views (even after refreshing) in SQL Mgmt Studio but NOT seeing them when you make your connection via the OLE/DB Provider using Crystal Reports?

 

Open the subject database using ACT! and click Help>About>Database Info.  That refreshes security and some base metadata.  Try and see if those Views appear now, perhaps the proper object security did not get applied for some reason, but I have not seen that happen before.

Bill Blakey
ACT! Development Team
Sage Software

New Member
Posts: 4
Country: Canada

Re: Custom Entities

Bill, I think this worked!

 

Thank you very much and I'll be sure to post if I have any further issues.

 

Regards,

 

David Nastrom