Community
Showing results for 
Search instead for 
Do you mean 
Reply

Cannot get any plugins to load

New Member
Posts: 4
Country: United_Kingdom

Cannot get any plugins to load

Hi Community, 

 

I've used a lot of the code examples and samples to really help me learn how to utilise ACT! but I'm not banging my head against a brick wall.

 

I've managed to write a program which will take information from a website database and synchronise it with ACT, so that changes to the website will be updated in ACT.

 

What i'm now trying to do is write a plugin which will do the reverse operation, update our web database when a button is pressed.

 

I've tried using the code examples from the SDK, I've also tried several VB and C# code examples other people have put up on the forum but every different one I have tried, the compiled DLL gets placed in the DependantDLLs file. I'm really confused as to why no plugins will load.

 

I even tried to strip a plugin down to being a blank plugin which did nothing, and it still got thrown into the dependantDLLs file.

 

So my questions are :-

 

1) Has anyone got an idea as to why no DLLs that I'm creating will load (some DLLs in the plugins load, some dont)

2) Does someone have some really simple code which will add a button to the contacts toolbar which will say "Hello World" in a message box (I can code everything from there)?

3) Alternatively, If I created a button which ran an external exe file, is there a way of me passing either the GUID, or a custom field into the executable? (thus allowing me to bypass the need for a plugin?)

 

System info :-

Sage ACT! Premium 2012 - Act for Windows

Windows 7 (32-bit) OS

 

Any help will be appreciated Smiley Happy

James

New Member
Posts: 4
Country: United_Kingdom

Re: Cannot get any plugins to load

Just putting this here because I realised I'm an Idiot!

 

For any others experiencing this issue the first thing to check.....

 

Make sure you are compiling in the correct .NET Framework.

 

For 2012 you need to use .NET 3.5 (not client profile)

 

I think for 2013 you use .NET 4

 

And I think 2011 and prior is .NET 2