Community
Showing results for 
Search instead for 
Do you mean 
Reply

An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

OK, will do. Just set you an email. 

 

T

Administrator
Posts: 268
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Got it.  Talk to you tomorrow.  We will share our findings with forum to figure out what the root cause is.

Administrator
Posts: 268
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Ok, for those of you on this thread, we did run tests on Tom's machine and it works as long as you are not running thru debugger.  Tom will contact me if he can reproduce this failing again in the future and I'll dig in again as needed.  Has anyone else out there had problems connecting to logon method via app or plugin when they don't have debugger attached or launched from studio?

Copper Super Contributor
Posts: 68
Country: USA

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

So, is there a solution for the ExecutionEngineException issue on debug? I've tried going back to v20.0, but I still get the issue.

Hugo Vale
Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

[ Edited ]

There isn't. You can't develop software with Act! 21. Fix is estimated for January. As for going back to Act! 20 on your development machine, I have been unable to do so since the V21 install. Still working on it.

 

After spending 2 days reverting back to Act! 20.1, I have now a working Act!. The problem is that when it installs, it autoupdates and downloads the crashing licensing .dll. Even though you are running Act! 20.1, the licensing .dll is still the same and crashes the development environment. So, I uninstalled Act!, disabled my internet connection and re-installed Act!. I now get the message: 

    Act_Error_Code.JPG

 

To conclude, the moment V21 is installed on the development machine, the development environment becomes VOID because Act! stops working. Reverting back to previous versions of Act! does not help.  If you are developing software for Act!, that is MAJOR. I am getting daily reports from customers that our software has stopped working and there is nothing we can do to help them.

 

 

 

Copper Super Contributor
Posts: 167
Country: USA

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

For now I tried Under Tools --> Options --> Debugging --> CHECK - Use Managed Compatibility Mode and run debug not release and it seems to work. Only works for an exe that uses the Actframework.
On a plugin I get the same error "An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProvider.dll"
We definitely need a fix.
Thanks,
Inge van Gemert
ACT! Certified Consultant
The Netherlands
inge@inkey.net
Copper Super Contributor
Posts: 68
Country: USA

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

[ Edited ]

Ok, so to resolve that Protexis message I went through these steps:

http://kb.act.com/app/answers/detail/a_id/23027/~/how-do-i-uninstall-and-reinstall-the-protexis-lice...

 

I have reverted back to v20.0, but like you said it installs update 9 that contains the bad licensing service. I'm going to try your internet disabling trick.

 

Thanks

Hugo Vale
Administrator
Posts: 268
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Rolling back is indeed a pain, but it does fix the issue. You need to make sure when you are re-installing you have your network disconnected and you apply update 1 - also without being on internet. I know some people like tom are getting the error message above and we are trying to figure out pattern/resolution as it seems to leave some remenents from the newest install when uninstalling that the reinstall is not happy about.
Copper Super Contributor
Posts: 68
Country: USA

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

I uninstalled v20.1 update 8 and installed ACT v17, but it still crashed while starting.

 

I then used the ACT_Uninstaller.exe to make sure everything would be spotless clean. 

 

Then a restart and installed ACT v20.0 with internet turned off, to make sure update 9 was not installed automatically.

 

I finally have my Visual Studio development back with plugins working within ACT.

 

Took me more than a day to figure this out, hope it helps someone.

Hugo Vale
Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

[ Edited ]

Were is this file ACT_Uninstaller.exe ? Does it come with the distribution? 

 

I've tried just about everything, including the steps on the article re. setting the Protexis service but to no avail. I still get the Protexis error. On my system, if the internet is not turned on, the act install fails miserably. I'd like to try this Act_Uninstaller.exe and see if that resolves the issue.

 

What about the developers at swiftpage come up with a quick patch? I'm now into my 3rd week down.

 

T