Community
Showing results for 
Search instead for 
Do you mean 
Reply

An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Billy,

 

Thank you for your reply. Yes, that assembly exists in the C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Act.Framework  folder. Should I delete it?

 

T

 

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

No, the folder is NOT empty. There is an Act.framework.dll there. Even if I rename this file, the error occurs.

 

Not sure what else to do.

 

T

--------------------------------

 

 

Do any of you see an empty assembly folder named v4.0_21.1.18.0__ebf6b2ff4d0a08aa when looking at your .net assemblies at C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Act.Framework ?

Administrator
Posts: 278
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

I have written the tester as you stated and it worked fine on my act v21 update 4 system.  Send me your tester app and I can see what the problem is...

I tested in debug and release as well and no issues.

 

 

I am very aware of inability to debug for plugins via studio etc, but writing against framework is working in my and our tests.  Also, it should be noted that custom tables is a plugin for Premium Plus and that is working fine as well. 

 

 

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Thank you for your response. Did you talk to Billy Clark ? He managed to duplicate the issue at your site.

 

I've attached a very simple project that crashes every time. It instantiates Act.Framework.actframework and opens the database. VERY simple. Crashes every time.

 

I'm running Windows 10 Pro with ACT 21 with update 4.

Also, I've made a video of the problem.

            Here's the link: http://www.123sync.com/dist/ActOpenError.mp4

 

Note, I was running Act! 20.1 and everything worked fine. I installed Act 21 and then started running our tests. I have not entered the license to activate the product.

 

Any ideas???

 

T

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Here is the direct link to the video.

   http://www.123sync.com/dist/ActOpenError.mp4

 

The link on the posting does not seem to work.

 

T

Administrator
Posts: 278
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Ok, let me take a look, I have the same environment you show above as well - Win 10, Act 21 Update 4. It's not a development machine, It's the one I use for demo's.
Administrator
Posts: 278
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Using your code it still works just fine for me, add an exception try catch and put messagebox with error, I think something must be wrong with image or dll is failing to load for some reason.

 

IS anyone else having this issue who is not trying to debug?

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

At the beginning of this thread, there are a few people that reported having the same issues. 

 

T

Highlighted
Administrator
Posts: 278
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Actually no, that is not what they are saying.  They are saying they are unable to DEBUG or attach a debugger, that is completely different from what you are saying and that's why I looked into it.  You are saying you cannot connect and login to the act! framework with the code above - even if you are not running via the debugger - Correct?

Astute Commentator
Posts: 197
Country: United States

Re: An unhandled exception of type 'System.ExecutionEngineException' occurred in Act.Shared.LicProv

Also, I have uninstalled and re-installed Act! multiple times to no avail.

 

T