Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act premium for web v17-login from WCF service fails

gkl
Copper Contributor
Posts: 29
Country: Ecuador

Act premium for web v17-login from WCF service fails

Hello, I have an Act premium for web v17 installation running on windows server 2012. I have instlaled act and enable the asp.net impersonation and everything working fine. I can use ther website for log in as well. I have created a service=WCF and I want to log in from the service in the Act database.

 

When i run my service in the debug mode of visual stidio I am getting this error warning  and when i click Continue I get logged in the Act database eventually. Looks like is retrying to connect.The problem is that when i deploy my service in the IIS it just never logs in and throws an error that service didnt log in.

 

The only related post I found is this, but this didnt work out for me.http://community.act.com/t5/Act-Developer-s-Forum/Framework-LogOn-failing-in-Act-v17/td-p/305136.

 

Copper Elite Contributor
Posts: 81
Country: Canada

Re: Act premium for web v17-login from WCF service fails

[ Edited ]

What user account is the web service's application pool running under? If its a local user, then to rule out any permission issues, maybe try changing the "Identity" to Local System. Oh and also make sure the application pool is running as 32-bit under the advanced Settings by setting "Enable 32-Bit Applications" to "True". 

 

When working with web services, the only two issues I have had when logging in is not running as 32-bit, and user not having approriate permissions.

Ahsan Khalid

Chief Technology Officer
Keystroke Quality Computing Inc.
www.keystroke.ca

gkl
Copper Contributor
Posts: 29
Country: Ecuador

Re: Act premium for web v17-login from WCF service fails

I have enabled 32bit for the application pool. My application pool is a wcfservicepool(same name as my website). The webservice is using the same application pool, wcfservicepoool. Is running under identity:Application Pool identity. I changed it to Local system as suggested but still no luck.

gkl
Copper Contributor
Posts: 29
Country: Ecuador

Re: Act premium for web v17-login from WCF service fails

It did the trick!!!Propably a restart o the IIS when changing the Identity to Local system was required. Thank you soo much!