Community
Showing results for 
Search instead for 
Do you mean 
Reply

Act.Framework.ProductVersionMismatchException: Error in the application

Tuned Listener
Posts: 7
Country: United Kingdom

Act.Framework.ProductVersionMismatchException: Error in the application

Hi,

 

Need some urgent help/advice.

 

I am getting a ProductVersionMismatchException when attempting to login to ACT BY SAGE PREMIUM 2008 (10.0) (ST Edition) 10.0.1.199 database using the SDK with code below -

 

 Dim framework As Act.Framework.ActFramework = New Act.Framework.ActFramework() 

framework.LogOn("c:\temp\act.pad", "ACTUser", "ACTPassword")

 

My visual studio project has the following references:

ACT.Framework.DLL (10.1.199.0)

ACT.Shared.Collections (10.1.199.0)

ACT.Shared.ComponentModel (10.1.199.0)

 

Please also note that the ACT database i am attempting to connect is through a VPN. Although the development machine has a local instance of ACT by Sage 2008.

 

Any help/guidance will be greatly appreciated.

 

Thanks.

Bronze Elite Contributor
Posts: 2,115
Country: United_Kingdom

Re: Act.Framework.ProductVersionMismatchException: Error in the application

Hi PPuri,

 

Just to make sure, the version of ACT! installed on your machine is an ST edition not an EX edition since that can also give that kind of error?

 

HTH

 

Vivek

Vivek Gargav
Caldere Associates Ltd.
www.caldere.com
vgargav@caldere.com
My Blog
Tuned Listener
Posts: 7
Country: United Kingdom

Re: Act.Framework.ProductVersionMismatchException: Error in the application

Hi Vivek,

 

Thankyou for your response.

 

The development machine i was initially working on had ACT 2008 whereas the web service i was developing using the ACT SDK was attempting to connect to a ACT 2008 Standard edition database over a vpn. If you recall my previous attempts were resulting in a ProductVersionMismatchException.

After your advice i started working on another machine which didnt have any version of ACT installed and now i am getting a

ACT.Framework.MissingMasterDatabaseException when i call the fwk.logon("ActUser","actpassword","actserver","actcontacts").

 

Any advice/suggestion/help would be greatly appreciated.

 

Thanks.

Copper Contributor
Posts: 12
Country: Australia

Re: Act.Framework.ProductVersionMismatchException: Error in the application

1) Could you clarify what ST and EX editions are (forgiving my ignorance).

 

2) I have NO Act installed on my client machine (the one trying to log on to the Act! database). I have simply copied all the Act.* dlls from the GAC on the Act server to my local machine, installed them in my GAC and referenced the three standard assemblies:

 

Act.Framework

Act.Shared.Collections

Act.Shared.Components

 

They are ALL version 11.1.183.0.

 

I get this exception when trying to log on. What does it mean? 

 

Bernd.