Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! and .NET Framework Versions

Nickel Super Contributor
Posts: 352
Country: Canada

ACT! and .NET Framework Versions

Hi All,

 

I'm still a little confused about what works with what.  I'm pretty sure on 6 out of 8 combinations below, but don't know for certain whether or not (see the red):

ACT! 2007 - 2012 can use a .NET 4.0 plugin assembly (I have some .NET 4.0 controls I'd love to use)

ACT! 2007 - 2012 can use a .NET 4.0 application.

 

Also, for both of those, if yes is there anything special you need to do to make it work?

 

Thanks,

Len

 

 .NET 3.5 Plugin Assembly.NET 4.0 Plugin Assembly.NET 3.5 Application.NET 4.0 Application
ACT! 2007 - 2012OK No?OK OK?
ACT! 2013+OKOKRequires the app.config file to include
<supportedRuntime version="v2.0.50727"/>
OK
Len Kamerman
ACT! Certified Consultant

Act E-mail Marketing Trainining Course:

http://actsoftware.training
Employee
Posts: 1,163
Country: USA

Re: ACT! and .NET Framework Versions

I can't speak for versions prior to 2010, but plugins referencing .Net 4.0 will fail to load in that version and in 2011/12. A framework level application ought to be able to reference any newer version of .Net so long as an application config file is included.

Matthew Wood
Act! SDK Support
Community Moderator
Nickel Super Contributor
Posts: 352
Country: Canada

Re: ACT! and .NET Framework Versions

Thanks Matthew - can you tell me what's got to be in the app.config file for .NET 4 apps to work with ACT! 2010 - 2012?

 

Thanks,

Len

Len Kamerman
ACT! Certified Consultant

Act E-mail Marketing Trainining Course:

http://actsoftware.training