Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT! Integration failure.

New Member
Posts: 5
Country: United States

ACT! Integration failure.

Hello,
I m creating a C# .NET Project in which i m trying to load ACT! Assemblies which are installed in GAC.

But in some machines I m getting an error stating "Unable to Load assembly of specified version 7.0.351.0".

when i tried to do an assembly redirection it didn't work it still shows the same error.

Note:
7.0.351.0 - Is the version with which it is compiled.

12.0.0.0 - Assembly present in the Target machine

Properties of Reference
Specific Version -> False

Aliases -> global

Copy Local -> False

 

This is my sample application configuration file
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <runtime>

    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1" >

      <dependentAssembly>

        <assemblyIdentity

                name="Act.Framework"

                publicKeyToken="ebf6b2ff4d0a08aa" />

        <bindingRedirect oldVersion="7.0.351.0"

                             newVersion="12.0.0.0" />
    
  
      </dependentAssembly>

    </assemblyBinding>

  </runtime>

</configuration>

I have not placed the assemblies in application path, I just want it to redirect to the version present in the GAC(12.0.0.0).

How do I Proceed with this?

Thanks in Advance.