Community
Showing results for 
Search instead for 
Do you mean 
Reply

ACT 2006 Plugins Stopped Loading

New Member
Posts: 9
Country: United States

ACT 2006 Plugins Stopped Loading

Hello!

 

I've just started developing for ACT! 2006 at a client, having taken over development of an established product. I've made upgrades to the plug-in before without trouble.

 

I have a plugin that consists of 2 assemblies and a .config file that is loaded along with the plugin. After a recent change, I copied the plugin to the ACT/Act for Windows/Plugins directory, and an exception was thrown at startup. I've had an exception like this before when I had malformed XML in the .config file. After shutting down ACT! I noticed there was a 2nd instance running, so I killed that with Task Manager.


After the exception I started up ACT! and my plugin wouldn't load.

 

I tried restarting ACT and making sure there wasn't another instance running in the background.

I tried restarting the computer.

I tried going back to a previous version of my plugin.

Nothing worked.

 

Using Filemon from Sysinternals, I verified that the plugin directory isn't even being read. So it would seem that somehow during this process I've tripped a "bad plugin directory" flag that is preventing all plugins from loading. But I can't see an option anywhere to enable/disable plugins. I've looked in the menus in ACT, the registry, the Act8.exe.config file.


Can anyone tell me if such a flag exists, or how to get my plugins re-enabled?

 

Thanks

/cm

Bronze Super Contributor
Posts: 1,231
Country: USA

Re: ACT 2006 Plugins Stopped Loading

cm,

Close, there is an XML file ACT! uses to bypass 'bad' plugins. Just close ACT and delete that file named DependentDlls.xml.

If your plugin does not load open the ACTLOG.XML to see details of why the plugin was skipped.

 

C:\Documents and Settings\Jim Durkin\Application Data\ACT\ACT for Windows 11\DependentDlls.xml

C:\Documents and Settings\Jim Durkin\Application Data\ACT\ACT for Windows 11\ACTLOG.XML

 

BTW - there is a LogViewer.exe to read the ACTLOG.XML file.

 

-- jim durkin

New Member
Posts: 9
Country: United States

Re: ACT 2006 Plugins Stopped Loading

Jim,

 

Thank you for your reply! I have solved the problem and your advice is pretty spot-on.


I  un- and  re-installed ACT! and thought I had run Update to get the latest version until I received the "You are running the latest version of ACT" message. I did discover that my plugin was listed in DependentDlls.xml at this point. I uninstalled again and found that the Application Data\ACT directory is NOT deleted on uninstall.

 

So I uninstalled, then deleted the Application Data\ACT directory and again, thought I had run Update until I was fully up-to-date. The plugin still wouldn't load. But in the end it turned out now that I was not on the current version that the plugin was built against. After upgrading fully the plugin loaded fine.

 

FYI, the original source of my problem was that an exception was being thrown in a global variable initialization in modMain (VB.NET) of the application. I've sinced moved that initialization code into the OnLoad handler wrapped in a Try/Catch block to prevent any possibility of this happening again.

 

Thanks for letting me know about the LogViewer. That will be very helpful in the future! It's also great to know that I can just delete the DependentDlls.xml file instead of reinstalling.

 

Thanks again! 

/cm 

Employee
Posts: 236
Country: USA

Re: ACT 2006 Plugins Stopped Loading

Here's a useful FAQ of sorts for plugin loading issues:

http://community.act.com/sage/blog/article?message.uid=135