Community
Showing results for 
Search instead for 
Do you mean 
Reply

Updated Contact Web Context Browser Control

Nickel Elite Contributor
Posts: 937
Country: USA

Updated Contact Web Context Browser Control

Here is the updated Contact context browser control.  The control has the following updates:

 

  • Control is compatible with ACT! 2009 (v11)
  • Additional Templates added
    1. Plaxo Lookup
    2. Jigsaw lookup
    3. WhitePages Reverse Telephone lookup
    4. WhitePages Reverse Address lookup
    5. Yelp

 

The control is rev'd as 1.2.0.0, to update existing control:

 

1.  Close ACT!

2.  Copy .dll and .xml files into ACT! install directory Tools folder (by defualt C:\Program Files\ACT\Act for Windows\Tools)

3.  Open ACT! - your existing tabs using this control should continue to work.

4.  To add additional control instances using the new templates refer to previous document on setting up this control.

 

 

For an explanation of why the control was updated for ACT! v11 look for future post in this thread.

 

FYI - updated Company Context Browser control (v1.2.0.0) also available.

Regards,

 

Allen

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Updated Contact Web Context Browser Control

Thanks for this... I'd missed it during the beta :-)

 

Do you know what was the change for ACT! 11 that didn't effect the other downloads here?

Nickel Elite Contributor
Posts: 937
Country: USA

Re: Updated Contact Web Context Browser Control

We're still sorting through some of the possible causes here but it's not likely an issue with v11 specifically.  I suspect that the originally posted compiled code referenced beta assemblies (the date was early August 07).  Any recompile of the original 1.1 source code will get you a working assembly, the 1.2 assembly has some minor optimizations (exception handling) and the xml file has additional templates.  

 

The behavior I see whenever the control has any errant code (and I've seen it plenty) is in runtime the control shows the design view (Click here to configure) but is of course unresponsive.  This is the behavior we've observed with the 1.1 compiled dll after any version change of ACT! (which is why I suspect the control itself is referenced specific beta assemblies or paths). 

 

The behavior has only been observed in these 2 controls and an additional (not yet published) Outlook control, but all other controls/plugins appear to not have any issues with the upgrade.

 

Ultimately any control/plugin should be forward compatible (you can see binding redirects in the config files for assembly versions) assuming the API's remain consistent (which they have in v11).  This looks like a one off case affecting these controls which we'll endeavor to fully understand and post here.

 

Regards,

 

Allen

Nickel Elite Contributor
Posts: 937
Country: USA

Re: Updated Contact Web Context Browser Control

[ Edited ]

Posting a view screen captures of the templates included in the contact web browser control.

 

The Twitter example is a good example of using the control to use custom defined fields to return directed data about the contact.

 

In the example I've added a twittername field to the contact record - the url for the control is:

 

http://twitter.com/{Contact.twittername}

 

Message Edited by alduet on 08-26-2008 02:01 PM
Message Edited by alduet on 08-26-2008 02:02 PM
Message Edited by alduet on 08-26-2008 02:07 PM
Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Updated Contact Web Context Browser Control

BTW: I've found this target URL works better for LinkedIn -

 

http://www.linkedin.com/search?search=&company={Contact.Company}&currentCompany=currentCompany&kwnam...

 Forcing Current Company and using Contact instead of Keyword should reduce the number of profiles it finds.

 

I haven't found a way do make it open the record automatically if only one record found ... they do have a Profile Key, but not sure how to read and add to the database when found as it only seems to be in the LI URL, and if that was used, would need a more complex Target URL to cover both options - if the Contact had that data (which wouldn't need to search) as opposed to not having it.

 

Join the ACT! Fanatics group at http://www.linkedin.com/e/gis/49896/5C904A501E66

 

Platinum Elite Contributor
Posts: 14,384
Country: Australia

Re: Updated Contact Web Context Browser Control

Interestingly, I was contacted by a user who couldn't get the new version to work with ACT! 2008 (10) but the old version did.

 

It seems the old ver can only work on 2008 and this one only on 2009. So there is obviously something that changed

Nickel Elite Contributor
Posts: 937
Country: USA

Re: Updated Contact Web Context Browser Control

[ Edited ]

Apologies in advance this is due to a misunderstanding on my end.  Being a relative novice to ACT! I read through all docs I could get my hands on before diving in, but I misread the part about assemblies being forward compatible but not backward compatible (I get forward and backwards mixed up all the time).

 

The version posted here was built on v11 and I would not expect it to work on previous versions of ACT!, I have a version built against v9 as well which did test well in v9 and v10 of ACT! which I should have posted, but alas with my many duties and distractions I copied the wrong assemblies and here we are.

 

Today I'll be setting up an ACT! v8 environment and building and testing against each version through v11  and reposting both this and the company web browser controls.

 

Again apologies for any confusion/issues with compatibility and this control.

 

We are working hard to get a feature related to this control in one of the v11 inlines and I would love to hear about additional URL's you would like to see included.

 

Thanks,

 

Allen

Message Edited by alduet on 09-05-2008 09:27 AM
New Member
Posts: 1
Country: Germany

Re: Updated Contact Web Context Browser Control

[ Edited ]

Hey,

 

we are using the google maps addin in our company. The problem is, since we have installed the google maps addin, that the act is verly slow when searching for some contacts or companies. Is this a known problem? What can we do against this performance bug?

 

I tried to delet all functions in Act.Devnet.ContecWebContextBrowser.xml whitch we are not using, without any success.

 

Thanks for help.

 

Benny

Message Edited by schrez_jr on 03-16-2009 04:02 AM
Nickel Elite Contributor
Posts: 937
Country: USA

Re: Updated Contact Web Context Browser Control

The control has a property called FetchURLOnlyWhenVisible which is default set to False.  This means that the browser control loads the web page each time the URL string changes (on movement of each record).  You may want to change this property to True so that the users machine only calls the URL when they have that tab open.  This would reduce overall performance demand from the control.

 

 

Copper Contributor
Posts: 7
Country: Italy

Re: Updated Contact Web Context Browser Control


alduet wrote:

 

The control is rev'd as 1.2.0.0, to update existing control:

 

1.  Close ACT!

2.  Copy .dll and .xml files into ACT! install directory Tools folder (by defualt C:\Program Files\ACT\Act for Windows\Tools)

3.  Open ACT! - your existing tabs using this control should continue to work.

4.  To add additional control instances using the new templates refer to previous document on setting up this control.


Hi, I've not installed the previous version of the control, but I'm willing to try it.

Is this procedure good to install the control for the first time?

I'm sorry but I could not find any Home Page / Download Page or Documentation about it. I'd be glad If you could provide me with some additional informations or link.

 

Thank you

Gabriele