Reply
New Member
cstore
Posts: 3
Country: United States
Message 1 of 9 (6,752 Views)

unable to share ACT database on a LAN

I have three computers on a LAN and would like them all to use the same ACT! 2009 database.  Unfortunately, I'm not sure how to do this.

I install ACT! on the first computer and it works just fine.  I share the directory where the database is saved, enabling read and write access.

On a second computer, I mount the shared directory as Z:\ and install ACT!.  When prompted for a "New Database", I enter in the same information that I entered in for the first one.  Same database name, same location, etc.  Unfortunately, doing this gets me the following error:

The specified location for your new database is invalid. A database must be created on a drive on your machine.

I hit cancel and then try to open a database.  As before, I go to the Z:\.  I click on the appropriate *.pad file and I get the following error:

The database ... could not be accessed.  In order to access this database, check your network connection and verify that your database server is available.  It may be necessary to disable any firewall software on your computer or the server.

As bad as an idea as that is (the firewall is there for a *reason*), I disable the first computers firewall and get the same error.

I then decide to click around, on the first computer, and come across Tools -> Synchronization Panel.  I create a "sync set" and then a remote DB "under" that "sync set".  I then go to Tool -> Synchronize -> Accept Incoming Syncs and go back to the second computer.  I try to open the newly created *.rdb file and get the following error:

The file type is not supported.  Please specify a valid ACT! database file type.

I then try some Google searches and come across this:

http://www.computing.net/answers/dbase/act-database/150.html

One of the posts says "try mapping the drive under Act again.  It works like regular mapping but is specific to Act".

Ok...  and how do I map it in this "Act specific" way?

Another post suggests that I edit the *.pad to make sure that the HOST attribute matched the name of the computer.  It does.  I can ping it and everything.

I try to open the *.adf file and get the following:

ADF files must be on a local device.  Files on mapped or shared drives cannot be used.

So I have no clue.  What do I need to do?  And please be as specific as possible.  Telling me to map the file in some "Act specific" way, when I don't know what that "Act specific" way is, is of no use to me.

Thanks.
Please use plain text.
Platinum Elite Contributor
GLComputing
Posts: 13,856
Country: Australia
Message 2 of 9 (6,739 Views)

Re: unable to share ACT database on a LAN

Please use plain text.
Platinum Elite Contributor
ghollister
Posts: 6,537
Country: USA
Message 3 of 9 (6,734 Views)

Re: unable to share ACT database on a LAN

Mike is correct.  No need to map drives when sharing an ACT database.  Also, ACT! (SQL) databases can only be created on a local hard drive of the machine hosting the database, not on a mapped drive.  They can be opened via a mapped drive (although it is advised that you use UNC mapping instead) from a client workstation, but not created on one.

Greig Hollister
Sage

Note: Effective 6/1/13, Sage no longers provides support for the Act! software

Please use plain text.
New Member
cstore
Posts: 3
Country: United States
Message 4 of 9 (6,727 Views)

Re: unable to share ACT database on a LAN

From the link GLComputing provided, it sounds like all I need to do is to copy the *.pad file from the host computer to the client computer (as opposed to opening the *.pad on the host computer via the SMB share).  Unfortunately, this yields one of the errors I've already encountered.  Namely:

 

The database ... could not be accessed.  In order to access this database, check your network connection and verify that your database server is available.  It may be necessary to disable any firewall software on your computer or the server.

As before, I've tried disabling the firewall, but it makes no difference.

 

Also, what is "UNC mapping"?

 

Please use plain text.
Platinum Elite Contributor
GLComputing
Posts: 13,856
Country: Australia
Message 5 of 9 (6,725 Views)

Re: unable to share ACT database on a LAN

Did you follow the other steps... like setting the ACT! database to Share?

 

That error is usually not the firewall. For all the possible reasons try each of the suggestion on this ACT! Knowledge Base article - http://tinyurl.com/4mauw7

Please use plain text.
New Member
cstore
Posts: 3
Country: United States
Message 6 of 9 (6,687 Views)

Re: unable to share ACT database on a LAN

The Share Database option is enabled and none of the issues mentioned in the troubleshooting guide seem to be the cause of my problems.

 

Specifically, Full Permissions are enabled (had to disable Simple File Sharing to ascertain this fact), the *.pad file isn't damaged (I just created it last Friday; how would it get damaged, anyway?), all the computers are running the same version of ACT (ACT! 2009), the SQL Server is enabled (if it weren't, I wouldn't even be able to connect from the machine hosting the database, which I am able to do), Protocols for ACT7; TCP/IP is enabled, the preference file isn't damaged, the database isn't damaged (again, if the last two were the cause, I don't think the copy on the host computer would even work), there are not multiple shares for the directories, and there are no problems with name resolution since I'm able to ping.

 

Half of these appear to be done by default, anyway.  The Share Database option seems to be enabled by default, there seems to only be one share for each folder created, by default, etc.  Which isn't surprising - I'm working with brand new installations of ACT! 2009 and haven't made any system changes of note since then (well, I've received a few emails since I installed it, which changes the contents of the hard drive ever so slightly, but no changes of note, like I said).

 

Although all that said, with regard to the multiple shares for the directories thing...  the instructions don't seem to be correct.  Right clicking doesn't show a "Stop Sharing" option.  The only two options I see, in fact, are "Refresh" and "Help".

 

Also, what does Tools -> Manage Users... do?  Maybe I need to do something with that to get this working correctly?  If so, it seems like http://tinyurl.com/4z4fyv should be updated to include that fact.

Please use plain text.
Copper Super Contributor
mkadlec
Posts: 54
Country: Canada
Message 7 of 9 (6,678 Views)

Re: unable to share ACT database on a LAN

I know you mentioned that the .PAD file isn't damaged because it was just recently created, but I want to be sure you did try deleting it and re-creating it by opening the .ADF file. The .PAD file contains information such as the host computer name and other database link information specific to that server. So if any of that information is changed, you will not be able to open the database.

 

Another thing you may want to try to be sure there is no network/DNS conflicts (a ping doesn't always reveal everything) is opening the .PAD file with a text editor and change the computer name in there to read the IP address instead.

 

Also virus software I don't think has been mentioned, are you running any on your host server that has some sort of active protection?

Michael Kadlec
Act! Certified Consultant
Corelogix Corporation
Please use plain text.
Tuned Listener
tbiapparel
Posts: 3
Country: United States
Message 8 of 9 (5,959 Views)

Re: unable to share ACT database on a LAN

Seriously i've tried and retried each of the steps mentioned in the instruction you mentioned and still unable to share the database on my network. I find this absolutely amazing!
Please use plain text.
New Member
johnnyd99
Posts: 3
Country: Canada
Message 9 of 9 (1,810 Views)

Re: unable to share ACT database on a LAN

Did this ever get sorted out? I'm having the exact same problem and have everything to no avail. Ideas??

Please use plain text.