Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
New Member
newit
Posts: 5
Country: USA
Message 1 of 2 (2,827 Views)

Network Sync port requirements

Greetings, all:

 

I am still pretty new to ACT!, and here is an issue or a request for information regarding an issue with syncing remote databases.

 

We are running ACT!  version 9.0.1.162 as the publisher and on all clients.

 

I have created a test RDB for this purpose, but the issue affects all RDB users who have had their RDB without issue for some time.

 

Everyone used to be able to sync databses, until around two weeks ago, when some VPN and firewall changes were made. Now, I suspected we had an issue with our VPN routing which it turns out we did, and now that it is straigtened out, our ACT server is reachable via VPN. No firewall rules have changed, and we're still allowing inbound TCP to act:65100. In fact, I can telnet to the port fine both internally and on an untrusted network through our SSL VPN. I get a goofy .NET error in my session which I just assume is the result of the server not knowing what I'm doing (or me not knowing what I'm doing). 

 

Anyhow, I still can't sync over the VPN. I also can't sync internally. The Network Sync Service (which I understand listens for incoming syncs when the main database is closed) is running, and it is managing sync connections for act:65100 for our main database that I had published the RDB from. 

 

I can confirm that the server is listening on TCP 65100 when I view my active connections. In fact, when I telnet to 65100 I can see that active connection as well, so it does not seem to be a TCP/IP communication issue.

 

I went into Tools, Synchronize and Accept Incoming Syncs is unchecked. I assumed that's because the Network Sync Service is running? Anyway, if I try to enable that on port 65100 and stop Network Sync Service while the database is open, I still can't sync up.  I have not tried both services together on different ports (maybe 65100 for NSS and 65101 AIS?). Honestly I'm not sure how the server was configured before the project was left to me.

 

The error message the clients see is ACT is unable to connect to the sync server. Check to be sure "accept incoming sync" is enabled in the maindataase and that the Network sync servic eis running. Also be sure you are connected to your network. 

 

Is there some configuration within ACT that I am just not seeing or understanding? 

 

Thanks!

 

:smileyhappy:

Please use plain text.
Platinum Elite Contributor
ghollister
Posts: 6,537
Country: USA
Message 2 of 2 (2,797 Views)

Re: Network Sync port requirements

Suggestions:

- Try another port altogether for the Network Sync Service, such as 65200

- The sync service may be damaged....try uninstalling and reinstalling the network sync service

- Make sure that the remotes and the main database are same the build (version) of ACT and that you using the 9.0.1 version of Network Sync

- Make sure the Network Sync Service is running as Local System account on the server

Greig Hollister
Sage

Note: Effective 6/1/13, Sage no longers provides support for the Act! software

Please use plain text.