Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
New Member
MarvelousMary
Posts: 3
Country: USA
Message 1 of 4 (7,236 Views)

Outlook 2003 Security Settings and HRESULT;0X800A01A8

Is anyone else experiencing challenges with Outlook Security Settings and ACT 10 Premium!!   When uncheck my Security Settings under the Outlook 2003 Automatic Picture Download to "Don't download pictures or other content automatically in HTML e-mail" and "Warn me before downloading content when editing, forwarding, or replying to email" I get errors. 
 
If the boxes are checked and all email is downloading content and pictures, everything works great and no messages in the Event Log.
 
If I uncheck these boxes and disallow download of content, I immediately get a "Exception from HRESULT; 0x800A01A8" when I try to reply to any email or forward an email in Outlook 2003 just working from Outlook without ACT 10 even open. 
 
That fires off a series of events in my Event Log.  After the HRESULT ERROR,  I get "  The process cannot access the file 'C:\Documents and Settings\USER\Application Data\ACT\ACT For Windows 10\HistoryQueue\tmp47.xml' because it is being used by another process."  I continue to get that error every 5 minutes until I reboot the machine.  It then goes away until I try to forward or reply to even a text email again and the whole cycle starts again. 
 
I have tested this on several of our XP Home and XP Professional machines and get the same error on Outlook 2003 when you change the security settings to not download pictures and content.  If I changed my email to get all content downloaded the error goes away.  I really don't want to get all that content I don't need in emails, does anyone have a solution to this problem?
 . 
Please use plain text.
Platinum Elite Contributor
GLComputing
Posts: 13,902
Country: Australia
Message 2 of 4 (7,230 Views)
Please use plain text.
New Member
MarvelousMary
Posts: 3
Country: USA
Message 3 of 4 (7,222 Views)

Re: Outlook 2003 Security Settings and HRESULT;0X800A01A8

It is when I open a message, and hit Reply or Forward with the message open.  It appears that there is a conflict with the message that Outlook usually fires off at this time regarding having to download the content before reply or forward.  I just get the famous Microsoft error noise and get the HRESULT error.  At that point I can cancel the error message and go ahead and forward the email.  I can do it one more time on any other email message (forward or reply to email) and get the same error again.  Then, if I try to reply or forward to another email,  I don't get the error on screen any more, but I keep getting Desktop History Queue errors in my event log every 10 minutes or so, until I reboot the machine and the whole exercise starts over again. 
 
If I just download all the pictures and content on my email, no problem with the ACT addon.  I would call this in, but everytime I get on the phone with support, they just want to rip everything out of my machine (ACT, Outlook SQL Server, etc) , including sometimes the registry and I don't want to do that any more, takes up too much of my time for program bugs that are inherent in the software.  I also don't want to have to get all the content in every email message in my Outlook.  It makes my Outlook way too big and creates the need to condense too often.
Please use plain text.
Platinum Elite Contributor
GLComputing
Posts: 13,902
Country: Australia
Message 4 of 4 (7,202 Views)

Re: Outlook 2003 Security Settings and HRESULT;0X800A01A8

There might be a bad file in the History Queue
 
ACT doesn't handle bad emails well. It puts items in the historyqueue to hold them until the email can go out. But it never does. Here's something that might help.

Setting Outlook History options default as "Record history" can negatively impact the performance of the DB host machine. Why? When this process
(not service) is active, each time a user sends a message, a copy of it is created in C:\Documents and Settings\<USER>\Application Data\ACT\ACT for
Windows 9\HistoryQueue as well as a identical file with an XML extension.

If the e-mail address of the recipient appears in ACT, both files disappear once they are attached to the contact in ACT.

Here's the catch: If the e-mail address can not be resolved, they files stay in the folder. The ACT.Outlook.Service constantly scans the HistoryQueue for messages and tries to find a match in ACT. Over time, this folder will fill up with messages.
 
With no one logged into the server, the ACT.Outlook.Service was consistently using 40% of the CPU. The Application folder in the Event Viewer was full of errors that alternated between reporting a problem with this process and then a 2nd error that said Value equals Null.

If we shut off the process, e-mail would not attach to contacts, either automatically or manually. What happens is as soon as you delete all the messages (not the two folders) in the Historyqueue, the CPU utilization for this process immediately dropped to 0.

So what does this mean to you? If you see this process constantly using the CPU on the DB host machine or you get DHQ errors, there may be unresolved message sitting in this folder.

Try deleting them and see how it goes.
Please use plain text.